Predefinição:Mapframe

Fonte: Wikivoyage
Saltar para a navegação Saltar para a pesquisa
[ver] [editar] [purgar] Template-info.svg Documentação da predefinição


Use este site para gerar uma instância da predefinição mais facilmente.

  • Uso: {{Mapframe|1|2|zoom=|height=|width=|layer=|staticmap=|align=}}
  • Parâmetros obrigatórios:
|1 latitude do centro do mapa, intervalo válido: -90.0 a 90.0
|2 longitude do centro do mapa, intervalo válido: -180.0 a 180.0
  • Parâmetros opcionais:
|zoom= nível de ampliação, padrão=14, intervalo válido: 2 a 17 ou auto (2=planeta, 17=quarteirão, auto=mostra todos os marcadores)
|height= altura do quadro de mapa, padrão=420px - deve ser de no mínimo 370px para dar espaço suficiente para o menu "layers" (camadas) se expandir
|width= largura do quadro de mapa, padrão=420px
|layer= camadas do mapa dinâmico, padrão=O (de Mapquest Open), válidas: M= Mapnik (OSM), W=Mapnik branco e preto (b&w), T=Turismo, N= Rede (Network) de transporte, R= Relevo, A= Mapquest Aerial, P= Pontos de interesse, L= Rótulos (Labels), H= Caminhada ao ar livre (Hiking), S= Sombreamento dos morros, C= Ciclismo, D= Destinos, G= trilhas GPX, B= limites (Boundaries). Pode-se combinar uma ou mais camadas livremente.
|staticmap= imagem de mapa estática, um arquivo png ou svg qualquer
|align= alinhamento do quadro de mapa, por padrão é à direita ("right", outros valores são "left" para a esquerda e "none" para centralizar)
  • Exemplos:
 {{Mapframe|51.47766|0.00115}}
 {{Mapframe|51.47766|0.00115|zoom=14|height=400|width=400}}
 {{Mapframe|51.47766|0.00115|zoom=14|height=400|width=400 |layer=W|staticmap=map.png}}
 {{Mapframe|51.47766|0.00115|zoom=14|height=400|width=400 |layer=MLSCG|align=none}}
  • Predefinição relacionada:
Depende de Template:PoiMap2 para gerar um link para o mapa externo.
  • Código:
Usado junto com um gadget: Mediawiki:Gadget-MapFrame.js. Se o gadget estiver desabilitado, usuários verão uma legenda com um link para o mapa dinâmico em tela cheia.
Usa parâmetros de dados HTML5 para passar variáveis ao iframe, exige uma consulta POST avançada para continuar afetando (atualizando?) o iframe.